Ошибка 81 в R-Keeper: причины и решение

Официальная карточка

Код
81
Система
R-Keeper
Категория
Общие ошибки
Описание
WS.Sys — System.ConfigChanged — Изменение конфигурации кластеров (добавление, удаление серверов из кластер). Клиент должен сохранять у себя актуальный список серверов. Обычно используется в паре с ошибкой 80. Например, в кластере 3 сервера (с1, с2, с3). Приходит сообщение 81 и новый список серверов (с2, с3, с4) - с1 отключается, с4 - добавлен. При попытке соединения с с1 будет появляться ошибка 80 с редиректом на другой сервер. Но когда сервер будет выключен, то 80 ошибка уже не будет приходить. Поэтому нужно обрабатывать код 81.

Почему возникает эта ошибка

  • Технические специалисты обновили или изменили конфигурацию серверов R-Keeper (например, добавили новый сервер или вывели старый из эксплуатации).
  • Произошел сбой на одном из основных серверов, и система пытается переключить кассы и станции на резервное оборудование.
  • Рабочая станция или кассовый терминал не смогли автоматически обновить список доступных серверов из-за кратковременного обрыва связи в локальной сети ресторана.
  • Проводятся плановые технические работы на стороне серверной инфраструктуры заведения.

Как исправить

  1. Дождитесь завершения автоматического перенаправления (часто сопровождается ошибкой 80) — система может сама найти новый рабочий сервер.
  2. Если работа заблокирована, перезагрузите кассовый терминал или рабочую станцию менеджера, чтобы принудительно обновить настройки подключения.
  3. Проверьте стабильность работы локальной сети в ресторане (убедитесь, что сетевые кабели подключены, а роутеры работают исправно).
  4. Свяжитесь с вашим системным администратором или службой технической поддержки R-Keeper для уточнения текущего статуса серверов.
  5. Убедитесь, что антивирусы или брандмауэры на рабочих станциях не блокируют доступ к новым IP-адресам серверов кластера.
  6. Если проблема не уходит, попросите техподдержку вручную прописать актуальные адреса серверов в конфигурационных файлах проблемной станции.

Похожие ошибки

  • Ошибка 80WS.Sys — System.Redirect — Команда клиенту “перейти на другой сервер”. Клиентский сервис должен перейти на работу с другим сервером (он будет указан в xml сообщении). На другом сервере необходимо повт

Устали разбираться с ошибками вручную?

DocsInBox автоматизирует работу с R-Keeper — проверяет данные до отправки, ошибки не возникают.

Источник проверен 20.09.2026, 00:09